Problems with my gaming build. SOLVED

So as you may or may not know recently I got a new gaming PC. It's quite nice but I had been running into a few problems with it. I did not build this PC I got it through Craigslist. The PC has been freezing up on me. I would say it happens at least once a day. It does not freeze up in the since that I can CNTRL ALT DLT my way out of it. Nope it has been locking up completely and the only way to get out of it is flipping the switch. So I had done some digging? What could this be? Hard drive? No because at least than I would get the blue spinning ring as if it was loading something. The temp of my CPU were a little high but nothing crazy. The ram was fine. When I first got the build I opened the panel glanced and put it back together. I didn't do to much looking. Today I did it again and spent some more time. Turns out the PC didn't even have an SSD installed. What I had thought was the SSD was just a 500 gig laptop hd. 
Yep there it is in my hand. This HD wasn't even mounted correctly or did it not have the brackets for it. The guy just screwed two screws into it and basically let it dangle. Oddly enough this wasn't even the issue. The issue came when I went to go look at the heat sink. It wasn't even tightened down correctly and it wasn't aligned correctly. When attaching the heat sink  there are four pins that tightened (get pushed down) on the the motherboard. 3 of those pins were not pushed down. Needless to say the heat sink was just hanging by a thread. I redid it and since 2 today (now 10 PM) I have not had an issue. Next week I will however be doing some upgrading to this PC along with just some basic hard ware improvements. One thing for sure is I will be getting a 1 TB SSD along with 8 more gigs of ram. 
Robert Bassett